Database Upgrade - Performance Degraded

Incident Report for Apero

Resolved

Tables have been re-synced and checks are looking good but please reach out if you have any questions!
Posted Sep 03, 2025 - 20:27 PDT

Update

Data written to the system in the last approximately 12 hours may not appear in the UI or in the API but is stored and will be re-synced later in the day.
Posted Sep 03, 2025 - 06:41 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 03, 2025 - 05:56 PDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 03, 2025 - 04:20 PDT

Identified

Intermittent errors are being experienced as a result of a database update. The engineering team is actively working on improvements. Refreshing the page more than is typical will be necessary as the team continues to work to address this issue.
Posted Sep 03, 2025 - 04:20 PDT
This incident affected: Dashboard and Invoices UI.