Invoice details are failing to load for some line applications

Incident Report for Apero

Resolved

This incident has been resolved.
Posted Nov 22, 2023 - 07:03 PST

Monitoring

We've identified the issue and a fix has been deployed.
Posted Nov 22, 2023 - 06:46 PST
This incident affected: Invoices UI.