Some payers are unavailable as we shift claims/eligibility alternative clearinghouse
Incident Report for Apero
Update
We are continuing to monitor for any further issues.
Posted Feb 27, 2024 - 02:07 PST
Monitoring
We have shifted claims traffic to alternative clearinghouses. Please contact your account manager for updated SLA's. Thank you for your cooperation.
Posted Feb 27, 2024 - 02:05 PST
This incident affects: Invoices UI and General Eligibility API.